
Chapter 19 | Death Reporting 

 

Introduction 

This chapter covers the end-to-end process for recording a 
Consumer death in iConnect. Monthly, Department of Health 
(DOH) Consumer data will be imported into iConnect to 
populate data fields on matching Consumer records. If a 
Consumer death has occurred and is recorded in the DOH 
data, the Date of Death, the DOD File Number, and the 
Cause of Death fields will be updated on the consumer’s 
Demographics records in iConnect.  

 

Date of Death – Manual Entry  

1. Upon receiving notification of a Consumer death, the 
Medical Case Manager (MCM) will update the consumer’s 
Demographic record. To begin, log into iConnect and set 
Role = Region Clinical Workstream Worker. Click Go.  

 
  

2. Search for and select the consumer’s record and click on the 
Demographics tab > select Edit > Edit Demographics. 

   
3. Update the following fields. 

a. Date of Death = update to correct date of death based 
on research found 



b. Vital Statistics Cause of Death = enter if known.  

c. DOD File Number = (If known. Otherwise, the field will 
be auto populated during the monthly scheduled 
interface job with DOH). 

 
 

4. Select File > Save and Close Demographics 

  

5. Upon saving the consumer’s Demographic record with a 
Date of Death, a Workflow Wizard will trigger the following 
Ticklers: 

a. Complete ROD – Assigned to Self (MCM), Due 
Immediately.  If anyone other than the MCM should 
update the DOD, he/she should reassign the tickler to 
the Clinical Lead for reassignment to the correct 
MCM.  

b. Create Alert Note notifying all that the ROD is in 
Process – Assigned to Self (MCM), Due Immediately. 
If anyone other than the MCM should update the 



DOD, he/she should reassign the tickler to the Clinical 
Lead for reassignment to the correct MCM. 

 

Report of Death Form & Alert Note 

1. The Date of Death was just added to the Demographic 
record and a Workflow Wizard triggers for the MCM (Self.) 
Click the tickler called Complete ROD.  

 

2. Upon doing so, a new ROD Report of Death form will open. 
Complete all relevant fields including: 

a. Review = Other 

b. Status = Pending 

c. Fill out ROD form in its entirety 

 

3. When finished, click File > Save Forms 

 

4. After the MCM creates the ROD with Status = Pending, a 
supervisor must review the report as described in the 
Supervisor review of ROD section. 

 
 

5. The MCM will return to the Workflow Wizard and select the 
Create Alert Note notifying all that the ROD is in Process 
tickler. 

 

6. Upon doing so, a new Consumer Note record opens. Update 
the following fields: 

a. Division = APD 

b. Note Type = Report of Death 

c. Note Subtype = N/A 

d. Description = OPEN ROD – DO NOT CLOSE 
DIVISION 



e. Note = Indicate that the ROD is in process  

f. Status = Alert 

 

 

Remember: 

DO NOT UPDATE THE STATUS OF THIS 
ALERT NOTE. 

Only State Office staff should change the status 
of this note to Complete.   

 

 

7. When finished, click File > Save Notes and File > Close 
Workflow Wizard   

 
8. The Supervisor review of the ROD is completed next.   

 

 

Supervisor Review of ROD 

1. After the MCM creates the ROD with Status = Pending, a 
supervisor must review the report.  Supervisors are defined 
on the Worker’s record in iConnect and are added as part of 
APD’s user provisioning process. 

 

2. iConnect will route the Pending ROD to the Supervisor of the 
MCM that completed the ROD form.  The Supervisor will 
access the Pending Assessments Queue to view the ROD 



 

3. The MCM Supervisor will review all ROD’s completed by the 
MCM.  

 

4. To begin, the Medical Case Manager Supervisor will log into 
iConnect and set Role = Region Clinical Workstream Lead. 
Click Go.  

 
 

5. On the My Dashboard, find the Tasks Section and scroll 
down to the My Management Panel. Click on the Pending 
Assessments Queue link: 

 
 

6. In the Pending Assessments Queue, click to open the form 
called Report of Death Form to review the form. 

 
 

7. If all required information is noted, set Status = Submitted 
and click File > Save and Close Forms. 



 
 

8. Should the MCM Supervisor find that the form is incomplete, 
or requires additional attention by the sending MCM, he or 
she can make changes to the form and/or will notify the 
MCM via a new Consumer Note record.  

 

9. To add the Note, navigate to the consumer’s record and click 
Notes > File > Add Note.  

 

10. In the new Note, update the following fields: 

a. Division = APD 

b. Note Type = Report of Death 

c. Note = Indicate which portions of the Form are 
incomplete 

d. Status = Pending 

e. Route the Note to the MCM by clicking the Ellipsis 
button next to Add Note Recipient. In the pop-up 
window, type in the Worker's Last Name and click 
Search. In the Search results, click on the matching 
Worker Name to route the note to that recipient. 

 

11. When finished, click File > Save and Close Note. 

 

12. Repeat the review cycle (adding relevant changes to the 
existing Report of Death form) until the ROD form updates 
have been complete. 

 

13. When all required information is noted on the Report of 
Death Form, MCM / MCM Supervisor will update Status = 
Submitted and click File > Save and Close Forms. 



 
 

Reassign Ticklers 

 

1. Upon saving the Report of Death Form with Status = 
Submitted, a Workflow Wizard will trigger the following 
Ticklers: 

a. Review Report of Death – Assigned to Self but 
Reassign to State Office Nurse, Due Immediately  

b. Enter/Validate DOD – Assigned to Self but Reassign 
to State Office Nurse, Due Immediately  

 
 

2. In the Workflow Wizard window, hover over the arrow next to 
each Tickler and click Reassign.  



 
 

3. In the Reassign Search window, type in the name of the 
State Office Nurse and click Search. Click on the matching 
record to send the Tickler to that user. The user will be able 
to access the reassigned Tickler via their My Dashboard.  

 

4. A tickler can on be assigned to one user at a time.  If 
additional users need to review the Report of Death, the 
State Office Nurse can reassign to that user after his/her 
review is complete.  

 

Review Report of Death 

 

1. The State Office Nurse will monitor the My Dashboard for 
Ticklers related to Reports of Death. To begin, log into 
iConnect and set Role = State Office Worker. Click Go. 

 

2. On the My Dashboard, finding the consumer’s section and 
scrolling down to the Ticklers Panel. Click on the Ticklers 
link: 



 
3. In the Tickler Queue, use the multi-variable search to narrow 

the results down to the relevant Ticklers. Click Search.  

 

 

Tip 

When searching for a future Tickler, remember 
to clear the check box next to Apply Alert Days 
Before Due prior to clicking Search.   

 

 

4. In the Tickler Queue, click to open the Tickler called Review 
Report of Death.  Upon doing so, the consumer’s Forms 
List View grid will open. 

 

5. Click to open the Report of Death Form and review it for 
completion.  

a. Update the Vital Statistics Cause of Death field if 
necessary.  This field should update automatically on 
the Demographics page from the DOH interface.  

b. Change the status from Submitted to Complete.  Do 
not mark the status as complete unless the Vital 
Statistics Cause of Death exists.   

 

6. When finished, click File > Save and Close Forms. 

7. When the ROD status has been changed to Complete, open 
ROD Note and update the following fields: 

a. Description = ROD COMPLETE- DIVISION MAY BE 
CLOSED  



b. Note = ROD COMPLETE (this can only be done by 
entering in New Text field and clicking “Append Text 
to Note) 

c. Recipients = Primary and Secondary workers listed in 
the Division Tab 

d. Status = Complete 

8. When finished, click File > Save and Close Notes. 

 

9. Return to the Workflow Wizard, select the flyout menu to the 
right of the Review Report of Death tickler and select 
Complete.  

10. If the Vital Statistics Cause of Death does not yet exist, do 
not mark the tickler as complete so it will remain in the tickler 
list as a reminder to the user to complete at a later date. 

 

11. Back in the Tickler queue, click to open the Tickler called 
Enter/Validate DOD. Upon doing so, the consumer’s 
Demographics record will open. 

a. Ensure that the Date of Death field has populated with 
the correct date. If changes need to be made, click 
Edit > Edit Demographics, update the relevant 
fields, and click File > Save and Close 
Demographics.  

 

12. When finished, hover over the arrow next to the Tickler to 
click Complete. Then click File > Close Workflow Wizard. 

 



 

 

Update Division Record 

1. When the Report of Death Screen Design is saved by the 
MCM with Status = Submitted, a Workflow Wizard Triggers 
the following tickler.  

a. ROD – Division Disposition Review - For Waiver 
Consumers, update disposition to Pending 
Disenrollment for all others, cancel the ticker and 
proceed to the case closure process. – Assigned to 
Primary Worker (Pre-Enrollment or Waiver Support 
Coordinator) Due Immediately 

 

2. The Primary Worker (Pre-Enrollment or Waiver Support 
Coordinator) will monitor their My Dashboard for Ticklers 
related to the ROD. To begin, log into iConnect and set Role 
= WSC/CDC. Click Go.  

 
 

3. On the My Dashboard, find the Consumers Section and 
scroll down to the Ticklers Panel. Click on Ticklers Due to 
access the Tickler Queue: 

 
a. Use the multi variable search to narrow down the 

results in the Tickler Queue. Click Search. 



 
  

 

Tip 

When searching for a future Tickler, remember 
to clear the check box next to Apply Alert Days 
Before Due prior to clicking Search.   

 

4. In the Tickler Queue, find the Tickler called ROD-Division 
Disposition Review.  Select the ticker to open. Upon doing 
so, the consumer’s Division List View Grid will open. 

 
 

5. Click to open the APD Division record. In the record, update 
the following fields: 

a. Disposition = Pending Disenrollment  

 

6. When finished, click File > Save Division.  



 
 

7. Return to the open tickler window.  From the tickler flyout 
menu, select Complete. 

 

 

Disenrollment Request 

1. The Pre-Enrollment or Waiver Support Coordinator will begin 
the case closure tasks and inform the Pre-Enrollment or 
Waiver Workstream Lead to send the request to Disenroll 
the Consumer to the State.  

 

2. To begin, log into iConnect and set Role = WSC/CDC. Click 
Go.  

 
 



3. Navigate to the consumer’s record and click Notes > File > 
Add Note. 

 
 

4. In the new Note record, update the following fields: 

a. Division = APD 

b. Note Type = Waiver Disenrollment 

c. Note Subtype = Pending Waiver Disenrollment 

d. Description = Due to Death 

e. Status = Pending 

f.  Attach the necessary documents 

g. Route Note record to the Waiver Work Stream Lead by 
clicking the Ellipsis button next to Add Note Recipient. In 
the pop-up window, type in the Worker's Last Name and 
click Search. In the Search results, click on the matching 
Worker Name to route the note to that recipient. 

 

5. When finished, click File > Save and Close Notes.  



 
 

6. The Waiver Work Stream Lead will monitor their My 
Dashboard for Notes related to Waiver Disenrollment. To do 
so, log into iConnect and set Role = Region Workstream 
Lead. Click Go. 

 

a. On the My Dashboard, locate the Consumers panel 
and scroll down to the Notes section. Click on the 
Pending link to open a queue of Notes with Status = 
Pending  

 
 

7. In the Pending Notes queue, open the Note record with Note 
Type = Waiver Disenrollment and Note Subtype = Pending 
Disenrollment: 



a. Review the contents of the Note to determine next 
steps. Update the Note accordingly.  

b. Leave Status = Pending 

c. Route the Note record ROM/Designee for approval by 
clicking the Ellipsis button next to Add Note 
Recipient. In the pop-up window, type in the Worker's 
Last Name and click Search. In the Search results, 
click on the matching Worker Name to route the note 
to that recipient. 

 

8. When finished, click File > Save and Close Note.  

 

9. The ROM/Designee will monitor their My Dashboard for 
Notes related to Waiver Disenrollment. Log into iConnect 
and set Role = ROM/Deputy ROM. Click Go. 

 
 

10. On the My Dashboard, locate the Consumers panel and 
scroll down to the Notes section. Click on the Pending link 
to open a queue of Notes with Status = Pending  

 
 

11. In the Pending Notes queue, open the Note record with Note 
Type = Waiver Disenrollment and Note Subtype = Pending 
Disenrollment: 

a. Review the contents of the Note and attachments 



b. Update Note Subtype = Waiver Disenrollment Approved 
OR Waiver Disenrollment Denied 

c. Set Status = Pending 

d. Route the Note record back to the Waiver Workstream 
Lead and the Waiver Support Coordinator by clicking the 
Ellipsis button next to Add Note Recipient. In the pop-up 
window, type in the Worker's Last Name and click 
Search. In the Search results, click on the matching 
Worker Name to route the note to that recipient. 

 

12. When finished, click File > Save and Close Notes. 

 

13. The Waiver Support Coordinator will monitor their My 
Dashboard for Notes related to Waiver Disenrollment. Log 
into iConnect and set Role = WSC/CDC. Click Go. 

 
 

a. On the My Dashboard, locate the Consumers panel 
and scroll down to the Notes section. Click on the 
Pending link to open a queue of Notes with Status = 
Pending. 

 

14. In the Pending Notes queue, open the Note record with Note 
Type = Waiver Disenrollment and Note Subtype = Waiver 
Disenrollment Approved or Denied 

a. In the Note record, review the ROM/Designee's 
decision. 

 

15. When finished, click File > Close Notes. 

 

16. To proceed with Waiver Disenrollment, the Waiver 
Workstream Lead will navigate to the consumer’s record and 
click Notes > File > Add Note.  



 
 

17. In the new Note record, update the following fields: 

a. Division = APD 

b. Note Type = Waiver Disenrollment 

c. Subtype = Request for Waiver Disenrollment Only OR 
Request to Disenroll and Return to Pre-Enrollment  

d. Status = Pending 

e. Route the Note record to the State Office Worker by 
clicking the Ellipsis button next to Add Note Recipient. In 
the pop-up window, type in the Worker's Last Name and 
click Search. In the Search results, click on the matching 
Worker Name to route the note to that recipient. 

 

18. When finished, click File > Save and Close Notes.  



 
 

Waiver Program Disenrollment 

 

1. The State Office Worker will monitor their My Dashboard for 
Note records related to Waiver Disenrollment. To do so, log 
into iConnect and set Role = State Office Enrollment. Click 
Go. 

 

2. On the My Dashboard, locate the Consumers panel and 
scroll down to the Notes section. Click on the Pending link 
to open a queue of Notes with Status = Pending  

 



3. In the Pending Notes queue, open the Note record with Note 
Type = Waiver Disenrollment and Note Subtype = Request 
for Waiver Disenrollment Only OR Request to Disenroll and 
Return to Pre-Enrollment  

 
4. Review the contents of the Note record and update the 

following fields: 

a. Note = Indicate whether the disenrollment request is 
approved or disapproved 

b. Status = Complete 

c. Route the Note record to the Waiver Workstream 
Lead and/or the Pre-Enrollment Workstream Lead as 
a Note Recipient by clicking the Ellipsis button next to 
Add Note Recipient. In the pop-up window, type in the 
Worker's Last Name and click Search. In the Search 
results, click on the matching Worker Name to route 
the note to that recipient. 

 

5. When finished, click File > Save and Close Notes. 



 
 

6. To disenroll the Consumer, the State Office Enrollment 
Worker will navigate to the consumer’s record and click on 
the Programs tab > open the APD waiver Program record. 

 
7. Update the following fields: 

i. Disposition = Disenrolled 

ii. Deactivated To = set to correct value 

iii. Deactivated Date = defaults to today’s date 

 

8. When finished, click File > Save and Close Programs.  



 
 

9. The Waiver Workstream Lead and/or Pre-Enrollment 
Workstream Lead will monitor their My Dashboard for Note 
records related to Waiver Disenrollment status.  

 

10. To begin, log into iConnect and set Role = Region Waiver 
OR Region Pre-Enrollment Workstream or Region Waiver 
Workstream Lead. Click Go. 

 
 

11. On the My Dashboard, locate the Consumers panel and 
scroll down to the Notes section. Click on the Complete link 
to open a queue of Notes with Status = Complete. 

 
 

12. Use the multi variable search to narrow down the search 
results. Open the Note record with Note Type = Waiver 
Disenrollment and Note Subtype = Request for Waiver 
Disenrollment Only OR Request to Disenroll and Return to 
Pre-Enrollment 

a. Review the contents of the Note. If the request was 
approved, create a new request for Case Closure via 



a new Consumer Note record.  Proceed to Case 
Closure section. 

 

 

Important! 

DO NOT CLOSE DECEASED CASES until 
State Office staff approval  

 

This step impacts ticklers and completion of 
tasks. 

 

 

Date of Death Interface 

1. Every 16th day of the month, a scheduled job will run to 
import data from DOH via an agreed upon file format into 
iConnect: 

a. Once imported, the consumer’s SSN and Date of 
Birth in the DOH data are compared with Consumer 
data within iConnect in order to locate a matching 
Consumer record. 

b. If an exact match has been identified, the system will 
update the consumer’s Date of Death, the DOD File 
Number, and set the DOD Action Field = Request 
COD on the consumer’s Demographic record in 
iConnect. 

c. These updates will then trigger a request for the 
Cause of Death field to be updated via the next 
monthly DOH data import. 

d. Note that for probable or inexact Consumer record 
matches, the consumer’s data will not import from 
DOH into iConnect. 



 
 

2. The State Office Nurse (or State Office Process Owner) will 
be able to review the Probable Match Report that identifies 
probable Consumer record matches between the DOH and 
iConnect data. Note that this report lives outside of iConnect. 

 

3. After reviewing the Probable Match Report, the State Office 
Nurse will navigate to the consumer’s record in iConnect and 
add a new Consumer Note record via Notes > File > Add 
Note. 

 

4. In the new Note record, update the following fields: 

a. Division = APD 

b. Note Type = Probable Match Report  

c. Note Subtype =Completed 

d. Status = Completed 

e. Route the Note record to the Waiver Clinical 
Workstream Lead by clicking the Ellipsis button next 
to Add Note Recipient. In the pop-up window, type in 
the Worker's Last Name and click Search. In the 
Search results, click on the matching Worker Name to 
route the note to that recipient. 

 

5. When finished, click File > Save and Close Notes. 



 
 

6. Based on the review of the Probable Match Report, updates 
to the consumer’s death details may need to be updated (if 
the fields were not already automatically updated via the 
monthly DOH data import). 

 

7. The State Office Nurse will navigate to the consumer’s 
record and click Demographics > Edit > Edit 
Demographics.  Update the following fields. 

a. Date of Death = update to correct date of death based 
on research found 

b. DOD Action = Request COD 

c. DOD File Number  

d. Cause of Death 

 

8. When finished, click File > Save and Close Demographics.   

 

9. When finished, proceed to the Chapter on Case Closure. 

 


